Настройка Vlan или как разбить сеть на несколько подсетей в Cisco Packet Tracer

Авг. 3, 2013 | Теги: Cisco Packet Tracer

Если вы не нашли ответ, то попробуйте найти его здесь

Здравствуйте читатели моего блога. Вот уже приближаются праздники, совсем скоро рождество у католиков, если среди вас они имеются, то я вас непременно поздравляю с сочельником. Сегодня я вам расскажу как настроить vlan на коммутаторе в Cisco Packet Tracer, вернее как их настраивать на оборудовании от cisco. Как повелось по традиции вся работа по настройке будет проходить в программе Cisco Packet Tracer. Кто еще не знает, что это за программа обязательно почитайте, это просто палочка выручалочка для тех у кого нет возможности поиграться с реальным оборудованием.

 

Давно я обещал написать статью о настройке не большой сети в Cisco Packet Tracer, но как то все откладывал, теперь пришел тот час когда я добрался до это замечательной программы. Сейчас больше времени уделяю другим рубрикам своего блога, рубрика сетевых технологий осталась без внимания, надо отдать ей должное.

Сразу давайте разберемся что такое Vlan? Кто еще не вкурсе могут прочитать в моей статье, ну я тем не менее напомню всем, что Vlan — это виртуальная локальная сеть, компоненты, (ПК, ноутбуки, телефоны) которой не обязательно находятся в одном физическом сегменте. Поясню, с помощью Vlan два компьютера могут быть объединены в локальную сеть даже если один из них в Москве, а другой в Питере.

Настройка Vlan в Cisco Packet Tracer

А на примере будем разбирать простую локальную сеть состоящую из семи компьютеров и одного сервера. Общая картина сети будет выглядеть так:

Настройка Vlan в Cisco Packet Tracer

 

конечно каждый может добавить необходимые элементы по вкусу, у меня общая схема, без промежуточных коммутаторов уровня доступа.

У нас имеется 7 хостов, 1 сервер, три коммутатора уровня распределения и один центральныйкоммутатор, и все это делится на три подсети, которые я выделил разным цветом.

Наша задача:

Разделить эти 7 хостов и сервер на три подсети так, чтобы эти подсети не видели друг друга, но все имели доступ к серверу. Настройка Vlan на коммутаторе cisco это дело 5-10 минут, так, что особо не переживаем.

Ниже я представлю свой вариант настройки сети в Cisco Packet Tracer, со всеми ip адресами. Да и сразу хочу отметить, что все настройки буду производить ручками, без всяких там DHCP, хотя с ним и удобнее, но это в следующий раз.

Как настроить Vlan на коммутаторе в Cisco Packet Tracer

Так выглядит окончательная схема сети с ip адресами и портами.

Настройка хостов в Cisco Packet Tracer

Теперь перейдем собственно к настройке, начнем с настройки хостов и сервера. На скрине видно, какие ip адреса я дал своим хостам и серверу, вы можете повторить за мной, либо назначить свои, главное не запутаться. Записывайте все конфиги либо как я на скрине чуть ниже, либо в блокноте, это очень экономит время. IP адреса я выбрал из десятой подсети, мне так удобно, маску подсети взял 255.255.255.0. Как настраивать хосты я описывал в прошлой статье, но для тех кто не читал и не хочет я напомню.

Чтобы попасть в меню в окно настроек хоста просто нажмите по нему левой кнопкой мыши, затем переходите в раздел Config, выберите интерфейс ( в нашем случае FastEthernet) и в нужных полях вбиваем адреса.

Настройка хоста в cisco packet tracer

 

Ничего сложного как видите. Обратите внимание, что по умолчание будет стоять маска 255.0.0.0, смело меняем ее на 255.255.255.0.

Разобравшись с настройкой хостов можно приступать к следующему этапу.

Настройка Vlan на центральном коммутаторе в Cisco Packet Tracer

Теперь настроим наш коммутатор, который на скрине изображен как Switch 3. Настраивать его будем через CLI ( командная строка для тех кто не в курсе). Для тех кто не знаком с командами советую ознакомится с моей рубрикой Cisco ICDN. Напоминаю, для того чтобы попасть в CLI нужно нажать на коммутатор и выбрать закладку CLI.

Switch3>en
Switch3#conf t
Switch3(config)#vlan 10
Switch3(config-vlan)#name VLAN10
Switch3(config-vlan)#exit

 

Настройка коммутатора в Cisco Packet Tracer

 

Все, что я сейчас описал проделываем для каждой VLAN.

Switch3(config)#vlan 11
Switch3(config-vlan)#name VLAN11
Switch3(config-vlan)#exit

И последнее

Switch3(config)#vlan 12
Switch3(config-vlan)#name VLAN12
Switch3(config-vlan)#exit

Теперь нам нужно настроить протокол VLAN Trunking Protocol. Этот протокол распределяет VLAN по всем коммутаторам в сети.

Настройка VTP и Trunk на коммутаторе в Cisco Packet Tracer

Настройка VTP проходит следующим образом:

Switch3(config)#vtp domain Findotvet
Changing VTP domain name from NULL to Findotvet
Switch3(config)#vtp password Findotvet
Setting device VLAN database password to Findotvet
Switch3(config)#vtp mode server
Device mode already VTP SERVER.

Все наш протокол готов к использованию. По плану настройка Trunk:

Switch3(config)#int fa0/1
Switch3(config-if)#switchport trunk encapsulation dot1q
Switch3(config-if)#switchport mode trunk
Switch3(config-if)#exit

Switch(config)#int fa0/2
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit

Switch(config)#int fa0/3
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit

На коммутаторе транковые интерфейсы будут пропускать через себя только трафик с маркером Vlan. Интерфейсы конечных коммутаторов нужно выставить в режим access, который будет пропускать только конкретный Vlan. И так идем далее и настраиваем коммутатор, который связан с сервером непосредственно (у меня это Switch2):

Switch2>en
Switch2#conf t
Switch2(config)#int fa0/4
Switch2(config-if)#switchport access vlan 10
Switch2(config-if)#switchport mode access
Switch2(config-if)#no sh

Теперь настроим клиента для протокола VTP

Switch2(config)#vtp domain Findotvet
Domain name already set to Findotvet.
Switch2(config)#vtp password Findotvet
Setting device VLAN database password to Findotvet
Switch2(config)#vtp mode client
Setting device to VTP CLIENT mode.

Сделать это нужно будет для каждого коммутатора кроме центрального. После этой процедуры протокол загрузит таблицы VLAN на коммутатор.

Настроим остальные порты этого коммутатора:

Switch2(config)#int fa0/3
Switch2(config-if)#switchport access vlan 12
Switch2(config-if)#switchport mode access
Switch2(config-if)#no sh
Switch2(config-if)#exit
Switch2(config)#int fa0/1
Switch2(config-if)#switchport access vlan 12
Switch2(config-if)#switchport mode access
Switch2(config-if)#no sh
Switch2(config-if)#exit
Switch2(config)#int fa0/2
Switch2(config-if)#switchport access vlan 12
Switch2(config-if)#switchport mode access
Switch2(config-if)#no sh
Switch2(config-if)#exit

Ну вот и все, один Vlan на одном коммутаторе настроен, можете попинговать хосты с этого Vlan. Теперь все тоже самое делаем для остальных коммутаторов. Я не буду описывать все это, надеюсь сами разберетесь, делаем все по аналогии настройки этого коммутатора, так же , только с указание своих Vlan. После того как все настроите пропингуйте узлы и посмотрите что получится. Узлы каждой Vlan пингуют только друг друга, остальных они не видят как и планировалось.

Vlan в действии

Как видно, у меня так и есть. Приступим к настройке маршрутизации на центральном коммутаторе

Настройка маршрутизации в Cisco Packet Tracer

На центральном коммутаторе настроим интерфейсы, отдельно для каждой Vlan:

Switch3#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch3(config)#int vlan 10

%LINK-5-CHANGED: Interface Vlan10, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up
Switch3(config-if)#ip address 10.0.10.1 255.255.255.0
Switch3(config-if)#no sh
Switch3(config-if)#exit
Switch3(config)#int vlan 11

%LINK-5-CHANGED: Interface Vlan11, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan11, changed state to up
Switch3(config-if)#ip address 10.0.11.1 255.255.255.0
Switch3(config-if)#no sh
Switch3(config-if)#exit
Switch(config)#int vlan 12

%LINK-5-CHANGED: Interface Vlan12, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan12, changed state to up
Switch3(config-if)#ip address 10.0.12.1 255.255.255.0
Switch3(config-if)#no sh
Switch3(config-if)#exit
Switch3(config)#int vlan 13

%LINK-5-CHANGED: Interface Vlan13, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan13, changed state to up
Switch3(config-if)#ip address 10.0.13.1 255.255.255.0
Switch3(config-if)#no sh
Switch3(config-if)#exit

Switch(config)#ip routing

Все готово, проверяем доступность каждого узла. Если все хосты пингуются значит все ровно. Теперь спрячем их друг от друга создав правила:

Switch(config)#ip access-list extended 100
Switch(config-ext-nacl)#permit ip any 10.0.10.0 0.0.0.255
^
% Invalid input detected at ‘^’ marker.

Switch(config-ext-nacl)#permit ip any 10.0.10.0 0.0.0.255
Switch(config-ext-nacl)#permit ip 10.0.10.0 0.0.0.255 any
Switch(config-ext-nacl)#permit ip 10.0.11.0 0.0.0.255 10.0.11.0 0.0.0.255
Switch(config-ext-nacl)#permit ip 10.0.12.0 0.0.0.255 10.0.12.0 0.0.0.255
Switch(config-ext-nacl)#permit ip 10.0.13.0 0.0.0.255 10.0.13.0 0.0.0.255
Switch(config-ext-nacl)#exit
Switch(config)#int vlan 10
Switch(config-if)#ip access-group 100 in
Switch(config-if)#exit
Switch(config)#int vlan 11
Switch(config-if)#ip access-group 100 in
Switch(config-if)#exit
Switch(config)#int vlan 12
Switch(config-if)#ip access-group 100 in
Switch(config-if)#exit
Switch(config)#int vlan 13
Switch(config-if)#ip access-group 100 in
Switch(config-if)#exit
Switch(config)#exit

Вот и все, теперь наш сервер доступен всем, а подсети закрыты Vlan-ами. Наслаждаемся результатом и гордимся проделанной работой, потом сохраняем проект если кому нужно и идем отмечать админский опыт.)

Получать новые статьи на Email

<< Cisco Packet Tracer Настройка cisco DHCP >>


Категории

Последние

Обсуждаем

Подписка на новости